Adrian Flux : 01553 845 945

The Toyota Landcruiser Owners Club
Landcruiser Club - Dedicated to Toyota Landcruiser, Amazon, Colorado and Prado Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
TLOCUK Club ShopClub Shop  TLOCUK Classified Ads serviceClassified Ads  dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs
TLOCUK HomeTLOCUK Home   TLOCUK ForumsTLOCUK Forums  Click here to link to the South African LandCruiser Owners Club websiteLCCSA  Click here to link to the Australian LandCruiser Owners OnLine website - possibly the longest established Land Cruiser club on the net!LCOOL  Click here to link to the IH8MUD website - run by extremely enthusiastic Land Cruiser owners, with a fantastic source of DIY information and useful forum!IH8MUD

Prado 150 injector problems...?


 
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 150 Series / Prado Technical Forum
View previous topic :: View next topic  
Author Message
shaymarriott
Newbie


Joined: 16 Jan 2018
Posts: 3
Location: Bristol, UK

PostPosted: Wed Feb 21, 2018 10:51    Post subject: Prado 150 injector problems...? Reply with quote

Hi all.

I posted in the Newbies section some time ago about considering a D4D 120 Series.  

Since then circumstances have changed somewhat and I am instead looking at a 150 - 2009/2010.

However a brief search of the internet indicates that in Australia and SA amongst other places, injector problems have once again started becoming apparent on the D4D engines.

However - I can't find anything online that mentions it occurring in the UK.

Is this something to be concerned about when looking for a 150?  Or is it OK over here due to better fuel? Perhaps it just happens on modern CR diesel engines?

Any thoughts from those more learned than me much appreciated.

Thanks, Shay.
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Wed Feb 21, 2018 10:51    Post subject: Google Ads keep this community free to join!


Back to top
andy
Moderator


Joined: 16 Dec 2003
Posts: 1923
Location: Polegate, Sussex, England.

PostPosted: Wed Feb 21, 2018 13:13    Post subject: Reply with quote

The only thing that I have seen is a fuel filter problem, this caused a loss of power after a few thousand miles, and Toyota have done a recall to change pipes and filter housing.
_________________
It's Not a Bl**dy Jeep it's a Landcruiser
100 Series VX Limited
Mercedes Sprinter 311 Luton
1993 VX80 4.2td SOLD
1996 Hilux Surf SSR-G Intercooler Sold
1994 Hilux Surf SSR-V Sold
Back to top
View user's profile Send personal message AIM Address
14all_and_all41
***


Joined: 23 Dec 2008
Posts: 172
Location: Aberdeen

PostPosted: Sat Mar 09, 2019 22:34    Post subject: Reply with quote

Hi I experienced the 120 injector seal failure, in fact I think I was one of the 1st on the 120 forum.

Been in my mind for the 150 series, but the sumps a completely different design, and Iím sure Toyota learnt theyíre lesson.

Iíve not had the inkling to check myself, but having the car since 20k mls, and now nearing 70k mls, no problems in this area as yet, fingers X.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 150 Series / Prado Technical Forum All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group