NFU Mutual - click to link

The Toyota Landcruiser Owners Club
Landcruiser Club - Dedicated to Toyota Landcruiser, Amazon, Colorado and Prado Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
TLOCUK Club ShopClub Shop  TLOCUK Classified Ads serviceClassified Ads  dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs
TLOCUK HomeTLOCUK Home   TLOCUK ForumsTLOCUK Forums  Click here to link to the South African LandCruiser Owners Club websiteLCCSA  Click here to link to the Australian LandCruiser Owners OnLine website - possibly the longest established Land Cruiser club on the net!LCOOL  Click here to link to the IH8MUD website - run by extremely enthusiastic Land Cruiser owners, with a fantastic source of DIY information and useful forum!IH8MUD

Klonk and loss of power


 
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 100 Series / Amazon Technical Forum
View previous topic :: View next topic  
Author Message
boonie
**


Joined: 01 Sep 2005
Posts: 78
Location: MIDDLESEX

PostPosted: Mon Jun 10, 2019 20:33    Post subject: Klonk and loss of power Reply with quote

Whilst towing my boat up a hill on the A30 noticed my Lc 4.7 wasnít pulling as good as it normally does, noticed the engine management light was on and flashing as I came down the hill heard a slight klonck and then loss of power, very lumpy until finally lost all power and engine died. Pulled over and tried starting but wasnít firing and sounded odd like only one side of the engine was turning over plus engine would continue to turn without holding key in place for a further 5 seconds. AA attended plugged in his laptop wasnít reading, came up no communication etc. He tried starting with easy start and when engine fired sounded terrible so called out transporter and recommended a garage just outside hayle in Cornwall which is a couple of miles down the road from me.
Just waiting to hear back from them on what the problem is?
New cam belt fitted 2yrs ago done just over 10k done
Overall mileage 127000 car is lpg conversion with flashlube
Never had any problems before but Iíve got a horrible feeling this is going to be expensive like a major rebuild valves etc? Any ideas please tell me Iím wrong?
Thanks in advance 👍
Back to top
View user's profile Send personal message Send e-mail AIM Address
Google
Sponsor





PostPosted: Mon Jun 10, 2019 20:33    Post subject: Google Ads keep this community free to join!


Back to top
Display posts from previous:   
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 100 Series / Amazon Technical Forum All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group