Adrian Flux : 01553 845 945

The Toyota Landcruiser Owners Club
Landcruiser Club - Dedicated to Toyota Landcruiser, Amazon, Colorado and Prado Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
TLOCUK Club ShopClub Shop  TLOCUK Classified Ads serviceClassified Ads  dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs
TLOCUK HomeTLOCUK Home   TLOCUK ForumsTLOCUK Forums  Click here to link to the South African LandCruiser Owners Club websiteLCCSA  Click here to link to the Australian LandCruiser Owners OnLine website - possibly the longest established Land Cruiser club on the net!LCOOL  Click here to link to the IH8MUD website - run by extremely enthusiastic Land Cruiser owners, with a fantastic source of DIY information and useful forum!IH8MUD

Registration Light Bulb


 
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> General Technical Forum
View previous topic :: View next topic  
Author Message
Spark
Newbie


Joined: 01 Jan 2019
Posts: 4
Location: Glasgow

PostPosted: Sun Jan 27, 2019 22:17    Post subject: Registration Light Bulb Reply with quote

I just went to change my registration light bulb and an 05 plate LC that i just purchased.

When i removed the housing i found it to be full of water and the bulb was smashed and kind of yellowish. Im sure the bulb was working when i got the car.

Had anyone else seen this?

Also now i have sharp glass protruding from the connector so no sure how to get it out?

Thanks in advance.
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sun Jan 27, 2019 22:17    Post subject: Google Ads keep this community free to join!


Back to top
DaveWall
******


Joined: 12 Nov 2007
Posts: 891
Location: Gloucestershire

PostPosted: Fri Mar 01, 2019 13:04    Post subject: Reply with quote

Long nose pliers and be careful - I see this often on other cars, usually the lenses/covers are better on the Jap stuff espcailly the Toyota's but you wouldn't be the first I guess... double check the fitting and cover see if you can see how the moisture got in...
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> General Technical Forum All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group