4x4 Mart magazine discount

The Toyota Landcruiser Owners Club
Landcruiser Club - Dedicated to Toyota Landcruiser, Amazon, Colorado and Prado Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
TLOCUK HomeTLOCUK Home   TLOCUK ForumsTLOCUK Forums  TLOCUK FaceBook GroupTLOCUK FaceBook Group
Click here to link to the South African LandCruiser Owners Club websiteLCCSA  Click here to link to the Australian LandCruiser Owners OnLine website - possibly the longest established Land Cruiser club on the net!LCOOL  Click here to link to the IH8MUD website - run by extremely enthusiastic Land Cruiser owners, with a fantastic source of DIY information and useful forum!IH8MUD  Yellow Diamond ClubsYellow Diamond Clubs

150 series Invincible Tyre pressure indicator


 
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 150 Series / Prado Technical Forum
View previous topic :: View next topic  
Author Message
shoaibm_2000
Newbie


Joined: 14 Sep 2019
Posts: 9
Location: UK

PostPosted: Tue Dec 27, 2022 22:16    Post subject: 150 series Invincible Tyre pressure indicator Reply with quote

Hi,
I had to get a jump start for my Toyota Landcruiser 150 series Invincible 97 registration.  I noticed that since the jump start, I am getting a 'tyre pressure' indicator on the main speed panel.

I checked the pressure and it was fine on all 4 tyres (30). Having increased the tyre pressure to 32 (the manual is confusing as in one place it says 30 and on another it states the pressure to be 32!), the indicator is still there and not going off. Once I start the car, it is displayed constantly.  

I was advised by some one that after pumping the air to the right level and driving the car for few miles it will turn off.  However, it is still there.

Has any one come across this issues and if so then what is the solution?

Please let me know.  Thank you in advance.
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Tue Dec 27, 2022 22:16    Post subject: Google Ads keep this community free to join!


Back to top
Tractionman
******


Joined: 07 Apr 2007
Posts: 821
Location: Bournemouth, Dorset

PostPosted: Wed Dec 28, 2022 10:54    Post subject: Reply with quote

There should be a reset button marked 'reset' under the dash somewhere above the pedals. Press with ignition on and wait for light to go out. All details on YouTube.
Also did you adjust the spare to the same psi as the other 4 - not sure if that's linked to the system
Back to top
View user's profile Send personal message
Tractionman
******


Joined: 07 Apr 2007
Posts: 821
Location: Bournemouth, Dorset

PostPosted: Sat Dec 31, 2022 14:08    Post subject: Reply with quote

Any updates ??
Back to top
View user's profile Send personal message
shoaibm_2000
Newbie


Joined: 14 Sep 2019
Posts: 9
Location: UK

PostPosted: Sun Jan 01, 2023 21:36    Post subject: Reply with quote

Hi ,
I managed to get it to reset following your advice using the 'reset' button under the steering wheel.  

Thank you for the guidance, greatly appreciated.
Back to top
View user's profile Send personal message
karl2000
****


Joined: 25 Apr 2021
Posts: 318
Location: North West

PostPosted: Mon Jan 02, 2023 16:49    Post subject: Reply with quote

How did you manage to get a 150 in 1997?
Back to top
View user's profile Send personal message
shoaibm_2000
Newbie


Joined: 14 Sep 2019
Posts: 9
Location: UK

PostPosted: Mon Jan 02, 2023 18:53    Post subject: Reply with quote

Hi,
The manual says Landcruiser 150 Prado for the 2017 model that I bought.
Back to top
View user's profile Send personal message
shoaibm_2000
Newbie


Joined: 14 Sep 2019
Posts: 9
Location: UK

PostPosted: Mon Jan 02, 2023 18:55    Post subject: Reply with quote

Apologies, I realised my typing mistake in the initial post.  the model is 2017 NOT 97 !
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 150 Series / Prado Technical Forum All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group